Follow

What are the technical requirements to use MiStable?

All you need is an Internet connection and a modern web browser. We recommend you use one of these commonly used web browsers:

Internet Explorer 9+

Google Chrome - latest version

Mozilla Firefox - latest version

Apple Safari 5+

Apple iOS 8

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.